Slow queries
Incident Report for Kissmetrics
Resolved
Our query systems experienced some temporary sub-optimal data access requests. While have mitigated the issue and will be making changes for further mitigation.
Posted over 3 years ago. May 31, 2016 - 09:14 PDT
Investigating
We are aware of reports hanging and are determining the cause.
Posted over 3 years ago. May 31, 2016 - 08:41 PDT